Traders Connect - MetaTrader connection issues – Incident details

MetaTrader connection issues

Resolved
Major outage
Started 9 days agoLasted about 3 hours

Affected

Platform Connectors

Major outage from 4:36 PM to 4:51 PM, Operational from 4:51 PM to 7:14 PM

Metatrader 4 - Primary

Major outage from 4:36 PM to 4:51 PM, Operational from 4:51 PM to 7:14 PM

Metatrader 5 - Primary

Major outage from 4:36 PM to 4:51 PM, Operational from 4:51 PM to 7:14 PM

Updates
  • Resolved
    Resolved

    Start: 16:28:15 UTC

    End: 16:44:15 UTC

    Duration: ~16 minutes

    Summary:

    Between 16:28 and 16:44 UTC, we experienced a service disruption affecting all MetaTrader 4 and MetaTrader 5 connections. This was caused by an unexpected outage from one of our Internet Service Providers (ISPs), which impacted routing to our primary firewall.

    What Happened:

    At 16:28 UTC, our monitoring systems detected a loss of connectivity due to a failure in our primary ISP. This triggered an automatic failover to our backup ISP, but the switchover took approximately 15 minutes to complete—longer than expected.

    During the failover window, our development team began implementing our disaster recovery (DR) plan, including preparing to migrate MetaTrader connectors to our backup datacenter. However, as connectivity was restored via the secondary route to our main site, the DR migration was halted and operations continued using the backup ISP at the primary datacenter.

    Current Status:

    All services were restored as of 17:44 UTC and are currently operating normally via the backup ISP.

    Next Steps:

    • Our networking team is actively investigating the root cause of the ISP outage.

    • We’re also reviewing why the failover process took longer than expected.

    • We’re in communication with the ISP to gain further insight into the disruption.

    We apologise for the inconvenience caused and appreciate your patience while we work to prevent similar issues in the future.

    — The Traders Connect Team

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating
    We are currently investigating this incident.