Traders Connect - MatchTrader Connector Issues – Incident details

MatchTrader Connector Issues

Resolved
Operational
Started 10 days agoLasted about 2 hours

Affected

Platform Connectors

Degraded performance from 10:19 AM to 11:24 AM, Operational from 11:24 AM to 12:04 PM

MatchTrader Connector

Degraded performance from 10:19 AM to 11:24 AM, Operational from 11:24 AM to 12:04 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We’ve identified the cause of the issue affecting our MatchTrader connector.

    Earlier today, MatchTrader experienced an issue on their API which caused our connector to lose connection with some accounts. When this occurred, our connector was unable to automatically reconnect, resulting in missed master trade events.

    Our developers implemented a fix and restarted the MatchTrader connectors. All connections are now restored and stable.

    The team is continuing to investigate the root cause in depth and is working on a long-term solution to ensure this does not happen again.

    Thank you for your patience and understanding.

  • Investigating
    Investigating

    We’re currently investigating an issue with our MatchTrader connector where some master trade events are not being received as expected. This is causing certain trade actions to be missed in some cases.

    Our development team is actively looking into the root cause, and we’ll provide further updates as we learn more.

    Thank you for your patience and understanding.