Scheduled for March 11, 2025 at 10:00 PM – 10:10 PM
Affects
Platform Connectors
Under maintenance from 10:00 PM to 10:10 PM
cTrader Connector
Under maintenance from 10:00 PM to 10:10 PM
Updates
Completed
March 11, 2025 at 10:10 PM
Completed
March 11, 2025 at 10:10 PM
Maintenance has completed successfully
In progress
March 11, 2025 at 10:00 PM
In progress
March 11, 2025 at 10:00 PM
Maintenance is now in progress
Update
March 11, 2025 at 10:00 PM
Planned
March 11, 2025 at 10:00 PM
Our developers need to restart our cTrader backend due to a critical bug causing trades to not be copied if they contain a Stop Loss or Take Profit. This fix will fix 90% of issues, however Fixed StopLoss and Fixed TakeProfit may continue to experience issues. The developers cannot release the fix for the remaining 10% until swap hours (22:00 UK).
Please note during this time your cTrader account will be reconnected.
The process should take no more than 30 seconds for your account.
Planned
March 11, 2025 at 11:44 AM
Planned
March 11, 2025 at 11:44 AM
The initial work has been completed. The developers will release the fix for the Fixed StopLoss + Fixed TakeProfit at 22:00 UK.