Traders Connect - FTMO Issues – Incident details

FTMO Issues

Resolved
Operational
Started 6 months agoLasted 22 minutes

Affected

Platform Connectors

Operational from 2:25 PM to 2:48 PM

Metatrader 5 Connector

Operational from 2:25 PM to 2:48 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Accounts are now reconnected, however the server appears unstable. As this issue is on FTMO's side all we can do is monitor the situation.

  • Identified
    Identified

    It appears FTMO are facing issues on their MetaTrader servers, the team have investigated and have confirmed the issue is on FTMO's side.

    We are waiting for them to make a fix.