Traders Connect - Broker delayed execution (resolved) – Incident details

Broker delayed execution (resolved)

Resolved
Operational
Started over 1 year agoLasted 41 minutes

Affected

Platform Connectors

Operational from 2:18 PM to 2:59 PM

Metatrader 4 Connector

Operational from 2:18 PM to 2:59 PM

Metatrader 5 Connector

Operational from 2:18 PM to 2:59 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We believe the issue was caused by a network route to Equinix, where 90% of trading brokers have their servers.

    The congestion appears to be resolved and trading speeds have improved.

    This issue was not an issue with our platform itself.

  • Investigating
    Investigating

    We are receiving reports of several broker servers having delayed execution speeds.

    Our development team are investigating the issue, at this point we do not believe the delay is with our platform itself.