Traders Connect - MetaTrader 5 timeouts – Incident details

MetaTrader 5 timeouts

Resolved
Major outage
Started 6 days agoLasted about 3 hours

Affected

Platform Connectors

Partial outage from 8:22 AM to 11:09 AM

MetaTrader 5

Partial outage from 8:22 AM to 11:09 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    The issue appears to have returned, our developers are actively investigating, however this looks to be the same issue as we've previously reported.

  • Monitoring
    Monitoring

    Earlier today, we experienced an incident where some trades were not executing and users encountered trade timeout errors.

    This was caused by a large-scale connectivity disruption affecting several major prop firm servers. As these connections dropped and re-established, a significant number of accounts attempted to reconnect to the Traders Connect platform simultaneously.

    This sudden surge in reconnections temporarily overwhelmed parts of our infrastructure, causing some Kubernetes pods to become unstable.

    Our engineering team responded immediately and scaled up the platform capacity to handle the increased load.

    Current Status:

    The platform is now stable, and trade processing has returned to normal.

    We will continue closely monitoring the system to ensure everything remains operating smoothly.

    Thank you for your patience.

  • Investigating
    Investigating

    We're currently experiencing higher than usual timeout rates with MetaTrader 5 connections.

    Our team are investigating the cause.