MetaTrader 5 backend updates
Scheduled for March 23, 2024 at 9:50 AM – 11:50 AM
Completed
March 23, 2024 at 11:50 AMCompleted
March 23, 2024 at 11:50 AMMaintenance has completed successfully
In progress
March 23, 2024 at 9:50 AMIn progress
March 23, 2024 at 9:50 AMMaintenance is now in progress
Planned
March 23, 2024 at 9:50 AMPlanned
March 23, 2024 at 9:50 AMWe will be deploying the latest MetaTrader 5 build during this window.