Scheduled for February 25, 2024 at 8:53 AM – 3:50 PM
Affects
Backend
Under maintenance from 8:53 AM to 3:50 PM
Internal API
Under maintenance from 8:53 AM to 3:50 PM
Web App
Under maintenance from 8:53 AM to 3:50 PM
Frontend
Under maintenance from 8:53 AM to 3:50 PM
Web App
Under maintenance from 8:53 AM to 3:50 PM
Completed
February 25, 2024 at 3:50 PMCompleted
February 25, 2024 at 3:50 PMcTrader has now been released to public BETA.
All users will receive email communication shortly.
Update
February 25, 2024 at 2:38 PMIn progress
February 25, 2024 at 2:38 PMThe team are making good progress releasing cTrader. It's taking a little longer than expected due to a few cases we need to handle.
We hope to have an update very soon with good news.
In progress
February 25, 2024 at 8:57 AMIn progress
February 25, 2024 at 8:57 AMMaintenance is now in progress.
Planned
February 25, 2024 at 8:53 AMPlanned
February 25, 2024 at 8:53 AMThe developers are currently in the process of releasing cTrader. This has been pushed forward due to the ongoing issues around prop firms.
Expect some disruption to our platform during this period.