Traders Connect - Traders Global Group issues (MFF) – Incident details

Traders Global Group issues (MFF)

Resolved
Operational
Started about 2 years agoLasted about 4 hours
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    MFF have confirmed there is an issue, all we can do is wait.

    If you use Traders Global Group you can expect to see a connection error during this time.

  • Monitoring
    Monitoring

    It appears Traders Global Group, the broker of My Forex Funds is having issues with their servers. We are noticing connection issues to the following servers:

    • TradersGlobalGroup-Demo

    Our team are monitoring the situation, however, the issue is with Traders Global Group and not our platform.